Answer of your leaving message
My iCam pro deluxe stop working. It has a solid blue light and I can not connect through the app or WiFi. I tried to reset but nothing happened, the light remained solid blue with no way to connect to camera.
Please help.
Thank you for your time !
Troy Lizama

2018-01-18 02:00:06****************************************
I followed the rebuild from external SD. I still have a solid blue light and can not reset. No motion at all.

2018-01-29 22:21:59****************************************
My camera is not responding to the F/W rebuilding. I am trying different AC cables. Do I send the unit back to you for repair? Or can you guide me with the next steps to take?

2018-03-14 22:20:31****************************************
I have tried everything you told me to try and I am not getting any results. I also tried different AC/cables and still no response from the camera only a non blinking blue light and no movement. I also changed SD cards to check i the SD card was a problem but the same results.

Please Help.
Troy

2018-03-14 22:35:22****************************************
I tried all the steps that you sent me and still I get no response from the camera only a non blinking blue light and no movement. I also tried using other AC/cables, I switch the SD card and I still got no response.

Please Help me get my camera up and running again.

by Troy Lizama


Dear Troy, thank you for contacting. If the camera does not response to the hardware reset ( no beep, no motor auto calibration ), then we may need to try the manual firmware rebuild as the last try. Thank you

1. Please check/exchange the AC and USB cable to cross check.
2. Please check/format the SD health by this tool
https://www.sdcard.org/downloads/formatter_4/index.html
3. Hardware reset and reinstall :
RESET: https://www.youtube.com/watch?v=VNvftkbS__c
INSTALL : https://www.youtube.com/watch?v=IR_m6dlKmAo /
https://www.youtube.com/watch?v=V-j_OzXsANo

If all above are not helpful after careful checking and verified.

Perform the manual firmware rebuilding

Rebuild the firmware from the external SD card :
This is a manual re-build firmware procedure for your reference (recovery and cure rate is more than 90% )

Download file
https://www.dropbox.com/s/w56gi1vzslm4781/icampro_362.zip?dl=0 [PC]

- Uncompress/unzip it to root directory of a MicroSD card [PC->SD]
- Insert the card to iCam or iBabi
- Plug power cord of it. CAM will auto detect the codes in the
Card to do the update ( blue light is on )
- Auto motor calibration/rotation (About 40~50 seconds)
- Wait till front blue led is blinking. (About 2-3 minutes)
- Unplug power cord
- Take card out.
- Plug power cord again and the blue led will keep blink ( waiting for installation )

Installation: https://www.youtube.com/watch?v=V-j_OzXsANo / If you are successful, please erase the card for normal use.

PS – this is what you see during the process Insert the card with unzipped files
Plug in power
Short beep ( camera detect and read the files ) in 5 seconds
After about 40 seconds Two short beeps ( writing complete )
Blue and Green lights blinking – done ( wrote in )
Unplug the power
Remove the SD and erase it



Dear Troy, may we know does the camera response to each steps of the F/W rebuilding procedures, especially the 1st step (read the card and short beep )? If you have completed the steps successfully, the camera does not get the blinking blue light in the end, the camera, SD or AC/cable (direct plug in another set as the cross check) may be defective assumed. Thank you



Please try this file. https://www.dropbox.com/s/mhl2l30tuxb0d6b/iCAM%20Pro_v421.rar?dl=0
And, let us know how the camera responses in details. Thank you